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1. Introduction 
The new Rainforest Alliance standard introduces risk as a key component of the certification process. 
Identifying and understanding local risks in agricultural supply chains can provide guidance to 
producers and supply chain actors as to where they should focus their improvements for maximum 
positive impact and minimum environmental effect. Incorporating environmental risks into the 
assurance process can equip auditors with more effective knowledge when carrying out checks and 
help them target the risky areas where agricultural practices are provoking negative environmental 
impacts. Rainforest Alliance has developed a QGIS risk assessment plugin to identify the risk of 
deforestation and encroachment into Protected Areas (PA), which in turn, could jeopardize 
compliance with the standard requirements and the expected sustainability outcomes.  
  
The QGIS RA risk assessment plugin consists of two components, namely; 

A. Validation tool 
B. Risk tool 

 

1.1. Validation tool 
The validation tool will detect certain “errors”, enabling the process to continue with the risk 
assessment tool and ensuring a certain level of data quality. The validation tool evaluates the 
following: 

• Farm unit IDs: 
o Missing check – All farm units must have a farm unit ID 
o Duplicate check – All farm unit ids must be unique and cannot be duplicated. 

 
The validation tool also evaluates the geolocation of the farm units, this consist of: 

• Waterbody check – Farm unit cannot be in water. 

• Country check – Farm unit must be in the right country (China). 

• Overlap check - Overlap check between farm unit geolocations. 
 

1.2. Risk tool 
• Deforestation risk 

o Evaluates whether a farm unit is located within areas where deforestation has been 
detected from 2014 onwards.  

• Encroachment into Protected Areas 
o Evaluates whether a farm unit is located within Go and No-go protected areas. 

 

2. Installing the QGIS RA risk assessment components 
Install the validation component and the risk assessment component. To install the QGIS RA risk 
assessment plugin, download the following zip files: 

• Geodata_RiskAssessment.zip 

• validation_tool.zip 

• ra_risk_tool.zip 
 

These files can be shared with you by the Rainforest Alliance, when you do not have the files, you 
can always contact Rainforest alliance and request the files. The Rainforest Alliance advises storing 
the data on your C-drive to reduce the risk of technical problems. 
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2.1. Geodata_RiskAssessment folder 
The first folder is the Geoda_RiskAssessment folder and contains all the data (layers) needed as 
input and the folder structure for the results. After downloading it, unzipped it and store it on C:\ 
drive (Figure 1). Please find below the folder structure detailed explanation: 
 

 
Figure 1. Folder structure 

 
Geodata_RiskAssessment folder structure 

• 1_Geodatabase (Folder 1) 
Contains the data layers that are needed to conduct the validation and risk assessment.  

❖ CountryBoundary (Folder 1.1) 
➢ Contains the Chinese country boundaries layer 

❖ Deforestation layer 
➢ Contains deforested areas layer (Forest cover – TCL) 

❖ ProtectedAreas (Folder 1.2) 
➢ Contains protected areas from the WDPA, including RA Go/No-Go 

classification. 
❖ Waterbodies (Folder 1.3) 

➢ Contains inland waterbodies (lakes) bigger than 10ha. 
 

• 2_CH_RiskAnalysis (Folder 2) 
In here the tools will store the input data and the results. It stores the CH input data per CH 
ID. 

❖ RA_ChinaExample1 (Folder 2.1) 
➢ 1_input_data (Folder 2.1.1) 

• It stores the input data (GMR, KML or SHP) with a timestamp (). 
 

 
Figure 2. Input files for "Example CH". 

➢ 2_secondary_outputs (Folder 2.1.2) 

• GMR_to_csv 
contains an excel csv which is used by the plugins to conduct the 
validation and risk assessment, this folder is only meant for the 
plugin. 
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➢ 3_results (Folder 2.1.3) 

• 1_validation (Folder 2.1.3.1) 
Contains the “Geodata validation table” which contains the results 
of the validation tool per farm unit ID.  

• 2_riskassessment (Folder 2.1.3.2) 
Contains the “Geodata risk table” which contains the results of the 
risk assessment per farm unit ID. 

 

2.2. Installation of the plugins 
After downloading the zipped files, open QGIS. To open QGIS go to “Windows start” and search for a 
folder called OSGeo4W, there you will find QGIS Desktop. In the example given in Figure 3 below you 
see the QGIS Desktop 3.24.3 in the red box. 
 

 
Figure 3. QGIS location on computer 

Opening QGIS you can now install the Plugins you have downloaded and are stored in the local drive. 
In QGIS go to “Plugins” > “Manage and install plugins…” to open the plugin window, see Figure 4 
below. 
 

 
Figure 4. The plugin location in QGIS 
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• Once the Plugin window is open (Figure 5), select install from ZIP and look for the 
“ra_risk_tool.zip” and click on Install plugin, repeat the steps “validation_tool.zip”. If a 
window pops up asking to trust the plugin source, click on yes. Once you install the plugins 
you will see the message “Plugin installed successfully”. 

 
Figure 5. Install the Plugin from the zipped file on the local drive 

 

• After installing the plugins, you will see that the “validation_tool” and “ra_risk_tool” plugins 
have been added to the QGIS toolbar. 

 
Figure 6. The location of the newly installed plugins 

The tool is periodically updated, so when requested please uninstall both plugins and download and 

install the new version. In QGIS go to “Plugins” > “Manage and install plugins…” > “Installed” and 

select the plugin and click on “Uninstall Plugin”.

 

Figure 7. Uninstalling a plugin 
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2.3. Activation of the plugins 
The “Python console” in QGIS must be activated before running both the Validation & Risk 
assessment plugins. The Python console will show the status, error messages, and results of the 
plugin tools. If you run across issues with running one of the plugins it indicates which issue you run 
into and where this occurred, and it also shows the results of the validation check. The validation 
plugin should be run always before starting the risk assessment plugin. 
 
As shown in Figure 8, you can activate the python console indicated in box 1. The activated python 
console will appear at the bottom of the screen as indicated in box 2. 

 
Figure 8. Activate the python console 

2.4. Validation plugin 
To start the validation plugin, select the validation icon . When the validation icon is pressed the 
validation tool window appears, see Figure 9 below. In the left top of the window, you can read that 
the validation tool window is open.  
In this window you can select:  

1. A GMR file to validate point data. 
2. A KML or SHP file to validate polygon data. 
3. Both a Point and Polygon file to validate both polygons and points at the same time. 
4. After you have selected the file(s), select OK. 

 
Note: The input files should be renamed after the CH id. An example is “RA_00123456789”. 

 
Figure 9. Validation tool window 

To successfully conduct the validation tool, the provided data must comply with the technical 
requirements.  
 
Points and polygons are different geometries and are provided in different file formats therefore, 
the requirements are different for points and polygons. 
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2.4.1. Geodata requirements for point 
The point data provided should comply with the requirements documented in Table 1 to prevent 
errors that enable the validation tool to be conducted successfully.  
 
Note: point data should be provided via the third sheet “3. Farm unit” of the GMR (annex S13). 
 
Table 1. Requirements for points (Sheet “3. farm unit” of the GMR) 

Column  Column name  Column Format  Guidance    

A  Internal Farm ID  Text  • No empty cells  

B  Farm unit ID  Text  • No empty cells 

• No duplicates  

• Farm unit IDs must be unique  

C  Farm unit area (ha) Number  • No text 

• No empty cells   

• One type of decimal separator (dot or comma)  

D & E  Latitude & Longitude Number  • No text 

• No duplicates 

• At least 4 decimals 

• Decimal Degrees format 

• One type of decimal separator (dot or comma)  

 

2.4.2. Geodata requirements for polygons 
The Polygons that are submitted should comply with the following requirements to prevent errors 
that enable the validation tool to be conducted: 

1. The polygon data must be in one of the following two formats: 
a. KML/KMZ 
b. Shapefile 

2. The file may only include polygons of the farm units representing the boundaries and no 
points or line data should be included. Avoid including the following: 

a. Polygons of farm infrastructure (House, office, plant, etc) 
b. (Poly)Lines of e.g., rivers, streets, and/or roads. 
c. Points of the farm units 
d. GPS tracklog 
e. Other information different from the farm unit polygons. 
f. Polylines 

3. The name of the polygon must be unique and represent the Farm unit ID 
4. All the polygon data must be provided in 1 file (either KML or SHP) 
5. In case the file is a SHP, the file must have the attribute “farmunitid” containing the unique 

farm unit IDs. 
6. Each polygon (farm unit) in the file must contain the unique farm unit ID. 
7. The Farm unit ID provided in the polygon file must be 100% the same as the farm unit ID 

registered in column B of sheet "3. Farm unit” of the GMR for that farm unit. 

(More information in topic 3 below). 
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2.4.3. Validation tool results 
The validation tool will provide the results inside the validation table and saves that table in the 
“1_validation” folder of the result folder explained in the  
Geodata_RiskAssessment folder chapter. 
The validation table shows for each farm unit a “Pass” or “Fail” on each check conducted.  
If a farm unit has a “Fail” on the first or second check, the other results will not be available because 
these will not be valid. 
 
The validation table contains the following information columns: 
 
InternalGroupMemberId Internal Group member ID is linked to the unique farm unit ID. 
Farmunitid   The unique farm unit ID of this location 
Latitude (points)  Latitude coordinate of the location 
Longitude (points)  Longitude coordinate of the location 
GeometryType   Indicates whether it is a point or a polygon 
CHnumber   Certificate Holder Organization number 
 
The validation tool conducts the following check divided into three different categories: 
 

1. data checks: 
farmunitID  Whether a farm unit ID has been provided, if not “Fail” 
duplicates  Whether the Farm unit ID is duplicated, if duplicated (not unique) “Fail” 
 
Note: To avoid duplicate fails when providing polygons and points. Provide only 1 type of geometry for each 
farm unit. Meaning: when a point and polygon for a specific farm unit is available, only provide the polygon. 

 
2. Geolocation checks: 

incountry  Whether the farm unit is in the country of CH, if not “Fail” 
inwater   Whether the farm unit is located in a waterbody, if so “Fail” 
 

3. Overlap checks: 
point_vs_point  Whether points are located within 20m of another point, if so “Fail” 
polygon_vs_polygon Whether a polygon is overlapping >20% with another polygon, if so “Fail” 
point_vs_polygon Whether a point is within a polygon, if so, both point & polygon “Fail” 
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2.5. Risk assessment plugin 
To start the risk assessment plugin, select the tree icon . When the tree icon is pressed the RA risk 
tool window appears, see Figure 10. In the left top of the window, you can read that the RA risk tool 
window is open. 

  
Figure 10. Risk Assessment tool window 

In this window you can select:  
1. A GMR file to validate point data. 
2. A KML or SHP file to validate polygon data. 
3. Both a Point and Polygon file to validate both polygons and points at the same time.  

 
After you have selected the file(s), select OK. 
 
Note i: The input files should be renamed after the CH id. An example is “RA_00123456789”. 
Note ii: The Validation tool must be conducted first. 
 
To start and conduct the RA risk tool, the validation tool must have been conducted successfully 
meaning that all the checks for each farm unit should have scored a pass. 
 
The RA Risk tool will provide the results inside the Geodata risk table and saves that table in the 
“2_riskassessment” folder of the result folder explained in the  
Geodata_RiskAssessment folder chapter. 
 
 

2.5.1. Risk assessment results 
The Geodata risk table contains the following information: 

CHnumber > Certificate Holder Organizational ID 
InternalGr > Internal Group member ID linked to the unique farm unit ID 
farmunitid > The unique farm unit ID of this location 
Area_(ha) > Farm units’ area in hectares 
Latitude > Latitude coordinate of the location 
Longitude > Longitude coordinate of the location 
Risk_PA > The farm unit’s encroachment into protected area risk level 
Risk_def > The farm unit’s deforestation risk level 

 
At the end of the risk assessment, you can add the data layers used the tool in QGIS. The data layers 
are stored in the “1_Geodatabase” folder explained in Chapter 2  
Geodata_RiskAssessment folder. 
The tool will automatically add the farm unit location layer in QGIS. 
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2.5.2. Deforestation Risk Map 
The deforestation risk assesses the possible non-compliance with Standard requirement 6.1.1. The 
risk assessment tool uses 3 different data layers namely: 

1. Farm location layers 
a. Point data 
b. Polygon data 

2. Forest cover layer (ESA satellites – Copernicus project data) 
3. Tree Cover Loss layer (Global Forest Watch, the Hansen dataset) 

 
The Risk tool will first look where the forest cover is located according to the Copernicus data, then 
the tool will overlay the forest cover data with tree cover loss data and extract the area where both 
layers overlaying with each other, this area is detected as deforestation and exported as a new 
deforestation layer. 
 
Secondly, the tool will now use the farm locations and see where the farm locations overlap with the 
deforestation layer and calculate how many percentages of the farm (unit) area is overlapping with 
deforested area. Based on the percentage, 3 risk levels will be assigned to the farm unit.  

1) Low risk – 0% 
2) Medium risk – more than 0% and 1.2% 
3) High risk – more than 1.2% 

 
 

2.5.3. Encroachment into Protected Areas (PAs) Risk Map 
The encroachment risk assesses the possible non-compliance with Standard requirement 6.1.2 
(production inside a PA). There are three risk categories: 

1) High - the farm unit (point) is located inside a classified No-go PA. 
2) Medium - the farm unit (point) is located inside a classified Go PA. 
3) Low - the farm unit (point) is not located inside a PA. 

 
The data used for this part of the risk assessment are the following datasets:  

1) Farm location data 
a. Point data 
b. Polygon data 

2) Protected areas (WDPA)  
 
The protected areas from the World Database of Protected Areas (WDPA) are assigned into two 
categories based on the IUCN classification given in the attribute table. The following two categories 
are created by RA: 

• No-Go area 

• Go area 
 
 More information on the Protected area classification can be found in Guidance D. Geolocation Data 
Requirements and Risk Maps. 
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3. Annex working with QGIS 

3.1. Adding a base map to QGIS 
It is possible to add a base map to QGIS to give a better spatial context to the farm layers added by 

the validation and risk assessment tool, to do this: 

 
1. Click on Plugins and select “Manage and Install Plugins” to open the install manager. 

 
 

2. Click on “Not installed”and  search for QuickMapServices and click on “Install Plugin” 

 
 

3. Once is installed, the icon of the plugin will be added to the toolbar. To activate the base 
map, click on the left icon > OSM > OSM Standard. 

 
 

3.2. Adding the deforestation and Protected Areas to QGIS 
It is possible to add the layers that are used by the Risk Assessment tool. 
This can be done by loading the Deforestation layer and/or the Protected Area layer into QGIS. 
In step 2 a reference is made to the name and the storage location of the layer.  
 
Deforestation layer:  
Name: Defo_layer_fixed.shp 
Location: C:\Geodata_RiskAssessment\1_Geodatabase\Deforestation 
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Protected area layer 
Name: ProtectedAreas_Apr2022_projected_fixed.shp 
Location: C:\Geodata_RiskAssessment\1_Geodatabase\ProtectedAreas 
 
To load the layer into QGIS follow the following steps: 

1. Select Layer > Add Layer > Add Vector Layer 

 
Figure 11. Add Vector layer 

 
2. The data source manager will be opened, in the search section, search for the layer’s 

location in the “C:\Geodata_RiskAssessment\1_Geodatabase” and  
3. Select the file you want to add either: 

• ProtectedAreas_Apr2022_projected_fixed.shp 

• Defo_layer_fixes.shp 

 
Figure 12. Opening the file location and selecting the shp file. 

4. Once the document is selected click on Add. 

 
Figure 13. Adding the file to QGIS 


